Auf Soundwechsel im Midifile reagiert mein Instrument nicht

Fragen zum Sequenzer/Eventliste/Grids oder MIDI-Bearbeitung

Moderator: Tyro

Antworten
Tyro
Globaler Admin
Beiträge: 131
Registriert: 31 Okt 2017, 08:01

Auf Soundwechsel im Midifile reagiert mein Instrument nicht

Beitrag von Tyro » 26 Mai 2018, 13:34

- Auch wenn es heute nicht mehr ganz so üblich ist :
Muss Ihr Instrument für das GM-Format umgestellt werden ?


- Überprüfen Sie, ob Sie ob Sie die Richtige Soundbank verwenden.
Verwenden Sie nicht nur GM/XG-Sounds und dann z.B. eine Korg Soundbank für ein Yamaha Instrument …
Dann kann es vorkommen das ein Program Change komplett ignoriert wird, wenn nicht zufällig der gleiche Befehl auch beim Yamaha Instrument vorkommt.

Denn Logischerweise muss Ihr Instrument über die Sounds verfügen.
Nur weil in einer Sequenzer-Soundbank Sounds angezeigt werden bedeutet das nicht, das Ihr Instrument auch die Sounds hat …


- Außer beim GM-Standart muss in der Regel auch der Bank Select (MSB/LSB) in jeder Spur im Midifile eingetragen sein und gesendet werden.
Hierbei ist darauf zu achten, das der Bank Select zuerst und dann der Program Change erfolgt und diese drei Daten nicht auf dem selben Ticker stehen.

Es kann auch vorkommen, das man vom Bank Select nur den MSB oder LSB angeben/eintragen muss.
Auch wenn dies sehr selten ist, aber …


- Überprüfen Sie ob Ihr Instrument oder Sequenzer Daten wie das Program Change/Bank Select raus filtert ?
Program Change und auch Bank Select müssen je nach "Richtung" gesendet/empfangen werden können.
Antworten